Virtualbox не видит шаблоны X64

Posted by

В очередной раз мне на Ubuntu Trusty () понадобилась помощью домашней виртуализации для тестирования одного функционала, в частности как настроить работу Zimbra + Autodiscovery, но вот не задача которая меня постигла. Virtualbox при создании VM почему-то вдруг отказался предложить мне изменить архитектуру у новой виртуальной машины, только x32

Virtualbox не видит 64-bit шаблоныЕсли честно я впервые с таким сталкиваюсь, в окне «Создать виртуальную машину» в ниспадающем списке «Версии» отсутствуют 64х битные версии шаблонов под виртуальную машину.
Проверяю, но систему я ведь поставил основную на свой ноутбук Lenovo E555 шестидесятиразрядную:

ekzorchik@navy:~$ uname -a

Linux navy 4.4.0-31-generic #50~14.04.1-Ubuntu SMP Wed Jul 13 01:07:32 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
ekzorchik@navy:~$ ps aux | grep VBoxSVC

ekzorch+ 10390 0.1 0.1 492652 16628 ? Sl 21:05 0:01 /usr/lib/virtualbox/VBoxSVC —auto-shutdown

ekzorchik@navy:~$ killall VBoxSVC
ekzorchik@navy:~$ sudo apt-get purge virtualbox* -y

ekzorchik@navy:~$ sudo rm -Rf /usr/lib/virtualbox
ekzorchik@navy:~$ wget http://download.virtualbox.org/virtualbox/5.1.12/virtualbox-5.1_5.1.12-112440~Ubuntu~trusty_amd64.deb
ekzorchik@navy:~$ sudo dpkg -i virtualbox-5.1_5.1.12-112440~Ubuntu~trusty_amd64.deb
ekzorchik@navy:~$ wget http://download.virtualbox.org/virtualbox/5.1.12/Oracle_VM_VirtualBox_Extension_Pack-5.1.12-112440.vbox-extpack
ekzorchik@navy:~$ sudo VBoxManage extpack install Oracle_VM_VirtualBox_Extension_Pack-5.1.12-112440.vbox-extpack

0%…10%…20%…30%…40%…50%…60%…70%…80%…90%…100%

Successfully installed «Oracle VM VirtualBox Extension Pack».
Странно, все как было и ничего не изменилось, но потом я вспомнил, что все таки за поддержку X64 отвечает мой BIOS, отправил основную систему в перезагрузку, а после в момент ее загрузки нажал клавишу F12 (вход в BIOS) — Security — Virtualization
параметр: AMD V(TM) Technology был выключен изменил на Enabled, затем нажал клавишу F10 (для сохранения настроек и перезагрузки).
Когда система загрузилась, запустил Virtualbox и при создании виртуальной машины все стало хорошо, шаблоны для шестидесятиразрядных систем на своих местах:

Vitualbox видит 64-bit шаблоныА то я испугался, что опять что-то не так и система меня подводит еще одним нюансом с которым я еще не знаком, а решение проблемы у меня под носом. Но все же я теперь знаю, что если не видно шаблонов версии при создании виртуальной системы значит нужно смотреть в настройки BIOS моего железа. Впредь буду умнее. А пока я хочу сказать всем до новых встреч, проблема казавшаяся на первый взгляд была успешно решена, с уважением автор блога Олло Александр aka ekzorchik.