Бесплатный Wifi на mikrotik без доступа к локальной сети

Posted by

Сегодня я для самого себя запишу все шаги которые нужно сделать на чтобы организовать Wifi сеть с доступом в интернет (т. е. Гостевая сеть), без какой-либо возможности попасть в локальную сеть за данным Mikrotik‘ом.

1. Проделываем первоначальные настройки

у меня локальная сеть (интернет подается) приходит во второй порт

2. Ниже я приведу пример моего скрипта выполнив который при восстановлении произойдет восстановление функционала до рабочего уровня если вдруг что-то произошло (вышло из строя/неосторожная настройка и т. д.):

Сохраняем/делаем бекап настроек с устройства MIkrotik в командный файл:

[admin@MikroTik] > export file=WifiFree.rsc

[admin@MikroTik] > system backup save name=WifiFree.backup

Saving system configuration

Configuration backup saved

aollo@system:~$ ftp 10.7.8.128

ftp> get WifiFree.rsc

local: WifiFree.rsc remote: WifiFree.rsc

200 PORT command successful

150 Opening ASCII mode data connection for /WifiFree.rsc (1861 bytes)

226 ASCII transfer complete

1861 bytes received in 0.00 secs (5733.1 kB/s)

ftp> get WifiFree.backup

ftp> quit

221 Closing

aollo@system:~$ file WifiFree.rsc

WifiFree.rsc: ASCII text

aollo@system:~$ md5sum WifiFree.rsc

06a8b19ac94c8456ebd492800cef6520 WifiFree.rsc

[admin@MikroTik] > export

# mar/19/2016 11:18:04 by RouterOS 6.34.2

# software id = 2LDB-56W2

#

/interface bridge

add name=bridgewififree

/interface wireless security-profiles

add authentication-types=wpa-psk,wpa2-psk eap-methods="" name=wififree \

supplicant-identity=""

/interface wireless

set [ find default-name=wlan1 ] band=2ghz-b/g/n country=russia disabled=no \

frequency=2432 guard-interval=long max-station-count=15 mode=ap-bridge \

security-profile=wififree ssid=wifi-free tx-power=19 tx-power-mode=\

all-rates-fixed wireless-protocol=802.11

/ip pool

add name=dhcp_pool1 ranges=192.168.33.2-192.168.33.254

/ip dhcp-server

add address-pool=dhcp_pool1 disabled=no interface=bridgewififree name=dhcp1

/queue simple

add max-limit=4M/4M name=queue1 target=bridgewififree

/interface bridge port

add bridge=bridgewififree interface=wlan1

/interface wireless access-list

add authentication=no disabled=yes forwarding=no interface=wlan1 \

signal-range=-70..120 time=0s-1d,sun,mon,tue,wed,thu,fri,sat vlan-mode=\

no-tag

/ip address

add address=192.168.33.1/24 interface=wlan1 network=192.168.33.0

/ip dhcp-client

add dhcp-options=hostname,clientid disabled=no interface=ether2

/ip dhcp-server network

add address=192.168.33.0/24 gateway=192.168.33.1

/ip dns

set allow-remote-requests=yes

/ip firewall address-list

add address=10.7.8.0/24 list=local

add address=172.11.11.0/24 list=local

add address=192.168.18.0/24 list=local

/ip firewall filter

add action=drop chain=forward dst-address-list=local src-address=\

192.168.33.0/24

/ip firewall nat

add action=masquerade chain=srcnat out-interface=ether2

/ip firewall service-port

set irc disabled=yes

set h323 disabled=yes

/system clock

set time-zone-name=Europe/Moscow

/system leds

set 5 interface=wlan1

/system ntp client

set enabled=yes primary-ntp=85.21.78.8

Небольшие пояснения,

  • local — это внутренние сети к которым доступ из wifi сети запрещен
  • 192.168.33.0/24 — сеть в которой работает DHCP-сервис выдаваемый IP адреса успешно подключившимися пользователям.

Допустим по случайности произошел возврат с дефолтным настройкам:

Winbox — IP&MAC — auth&pass — System — Reset Configuration

Порядок восстановления:

  • Чтобы восстановить из этого скрипта функционал Mikrotik нужно скопировать все команды в текстовый файл и сохранить с расширение rsc или же через ftp скопировать бекап с устройства Mikrotik на рабочую станцию
  • Для нового устройства произвести первоначальную настройку (IP,SNTP,Clock,Packages)
  • Посредством FTP закачать на устройство данный файл с расширение rsc:

ftp> put WifiFree.rsc

ftp> put WifiFree.backup

local: WifiFree.rsc remote: WifiFree.rsc

200 PORT command successful

150 Opening ASCII mode data connection for ‘/WifiFree.rsc’

226 ASCII transfer complete

1859 bytes sent in 0.00 secs (9309.9 kB/s)

ftp> quit

221 Closing

  • Подключиться к устройству (либо через winbox, либо по ssh) и запустить данный скрипт

и функционал устройства Mikrotik будет восстановлен.

aollo@system:~$ ssh -l admin 10.7.8.128

The authenticity of host ‘10.7.8.128 (10.7.8.128)’ can’t be established.

RSA key fingerprint is d1:fa:c2:73:5b:47:6d:75:34:cd:2e:9c:3f:4c:f5:78.

Are you sure you want to continue connecting (yes/no)? Yes

[admin@MikroTik] > import file-name=WifiFree.rsc

а лучше восстанавливать из бинарного бекапа:

[admin@MikroTik] > /system backup load name=WifiFree.backup

после устройство Mikrotik будет перезагружено

отлично функционал устройства Mikrotik успешно восстановлен из бекапа.

Просто эта заметка шпаргалка на всякий будущий случай когда что-то пошло не так и нужно восстановить функционал устройства Mikrotik. На этом всё и до встречи, с уважением автор блога — ekzorchik.