Уведомление о завершении бекапа с Mikrotik на почту

Posted by

А я думал, что уже выложил данную заметку на свой кладезь знаний работы системного администратора, а вот оказало что нет. Да и к тому же я еще не полностью оптимизировал поисковый механизм на своем блоге. Вот ищу, пробую и так и этак ввод ключевых фраз, а искомой страницы на блоге нет. Глянув черновики — обнаружил ее не до конца оформленную. Дело в том, что в односчастье мне потребовалось уточнить , когда последний раз точка доступа по предоставлению бесплатного Wifi делала бекап чтобы из него восстановить работоспособность вследствие своих экспериментов. Поиск по каталогу куда складируются бекапы показал, что последняя дата это конец мая, а на дворе уже 20 числа июня, хорошо хоть ничего на ней (точке доступа не изменялось, а то всего не упомнишь), я восстановил работоспособность:

  • Затем копирую с FTP-ресурса бекап от 29 мая 2016 года к себе на рабочую станцию:

ekzorchik@srv-mon:~$ scp WifiFree_may-29-2016_1w.backup aollo@10.7.8.135:/home/aollo

  • Затем подключаюсь к точке доступа и копирую с рабочей станции бекап:

aollo@system:~$ ftp 10.7.8.63

Connected to 10.7.8.63.

220 WifiFree FTP server (MikroTik 6.35.2) ready

Name (10.7.8.63:aollo): admin

331 Password required for admin

Password:

230 User admin logged in

Remote system type is UNIX.

ftp> put WifiFree_may-29-2016_1w.backup

ftp> quit

221 Closing

  • Затем подключаюсь по ssh к точке доступа для запуска команды восстановления из бекапа:

aollo@system:~$ ssh -l admin 10.7.8.63

[admin@WifiFree] > system backup load name=WifiFree_may-29-2016_1w.backup

После перезагрузки работоспособность восстановлена.

Если я правильно понял то скрипт осуществления резервной копии остается таким же лишь с малыми дополнения по определению почтового сервера и куда отправлять уведомление:

Дорабатываю вот эту заметку:

Исходные данные по оборудованию: (Хотя все действия скрипта применимы и к другим Mikrotik‘ам.

(MikroTik RouterOS 6.34.4)

У меня почта в сети крутится с использованием почтового сервера Zimbra аутентификационные данные взяты с него.

Отправка резервной копии по почте:

[admin@MikroTik] > tool e-mail send to=alexander.ollo@nemdom.ru from=mikrotom.ru server=10.7.8.240 port=25 subject="Backup Mikrotik" file=MikroTik_apr6_08:16:06.backup

Резервная копия пришла на почту

[admin@MikroTik] > tool e-mail send to=alexander.ollo@nemdom.ru from=mikrotik@nemdom.ru server=10.7.8.240 port=25 subject="Backup Mikrotik rsc script" file=MikroTik_apr-16-2016_08:16:06.rsc

Теперь скрипт с учетом дополнений выглядит следующим образом:

log info "Starting Automatic Backup Script"

:global thisdate [/system clock get date]

:global time [/system clock get time]

:global datetimestring ([:pick $thisdate 0 3] ."-" . [:pick $thisdate 4 6] ."-" . [:pick $thisdate 7 11])

:global backupfilename ([/system identity get name]."_".$datetimestring."_$time")

:local ftpusername "mikrotik"

:local ftpuserpassword "712mbddr@"

:local ftphostname "10.7.8.120"

/system backup save name="$backupfilename"

:delay 5s

/export compact file="$backupfilename"

:log info "Please wait…!!!"

:delay 5s

:log info "Sending Backup Mikrotik to FTP Server…………."

/tool fetch address="$ftphostname" src-path="$backupfilename.backup" user="$ftpusername" password="$ftpuserpassword" port=21 upload=yes mode=ftp dst-path="$backupfilename.backup"

:delay 1

/tool fetch address="$ftphostname" src-path="$backupfilename.rsc" user="$ftpusername" password="$ftpuserpassword" port=21 upload=yes mode=ftp dst-path="$backupfilename.rsc"

:delay 1

:log info "Sending Backup Mikrotik to Mail Server…………."

:local toemail "alexander.ollo@nemdom.ru"

:local fromemail "mikrotik@nemdom.ru"

:local emailserver "IP-address-Mail-Server"

/tool e-mail send to=$toemail from=$fromemail server=$emailserver port=25 subject="Backup backup data" file="$backupfilename.backup"

:delay 1

/tool e-mail send to=$toemail from=$fromemail server=$emailserver port=25 subject="Backup rsc script" file="$backupfilename.rsc"

#Allow time to send

:delay 10s

/file remove "$backupfilename.backup"

/file remove "$backupfilename.rsc"

:log info "Finished Backup Script…!!!!"

:log info "Sending Backup Mikrotik to Email …………."

Запускаю данный скрипт в ручном режиме:

[admin@MikroTik] > system script run FTPBackup

Saving system configuration

Configuration backup saved

status: finished

downloaded: 35KiB-z pause]

total: 35KiB

duration: 1s

status: finished

downloaded: 5KiBC-z pause]

total: 5KiB

duration: 1s

Смотрю отправился ли отчет по FTP:

ekzorchik@srv-mon:~$ ls /var/ftp/ftp-mikrotik/ -l

total 44

-rw-r—r— 1 mikrotik mikrotik 36237 Apr 16 09:11 MikroTik_apr-16-2016_09:11:13.backup

-rw-r—r— 1 mikrotik mikrotik 5130 Apr 16 09:11 MikroTik_apr-16-2016_09:11:13.rsc

Смотрю отправился ли отчет по почте:

Backup & RSC файлы отправились и на FTP и на почту

Отлично все отработало как надо.

Теперь по приходу на работу я просто не только по своему составленному чек листу проверяю все ли за ночь отработало как надо, но и проверяю, а создалась ли резервная копия конфигурационных файлов сетевого оборудования Mikrotik. Вот с каждый разом разбирая и внедряя что-то одно у меня рождаются мысли как это можно оптимизировать или просто сделать по другому, чтобы подстраховать в первую очередь самого себя от всяких форс мажорных обстоятельств. Ладно не буду больше разглагольствовать, поставленная самому себе задача настроена, выполнена и практична. Это так называемый задел на будущее. На этом я прощаюсь до новых встреч с уважением автор блога — ekzorchik.